Contagem com valores repetidos

Contagem com valores repetidos é uma dúvida recorrente em Excel, pois não existe uma função pronta para tal finalidade, mas sim técnicas que quando bem aplicadas resultam em formulas extremamente interessantes, sendo assim, veremos 2 maneiras para se atingir a um mesmo objetivo.

Utilizaremos a seguinte base de dados para exemplificar as técnicas empregadas.

alunos
Figura 1 – Base de dados utilizada para a contagem com valores repetidos

Contagem com valores repetidos

1ºModo


 {= SOMA(1/CONT.SE(Intervalo;Intervalo))}

Utilizando a base de dados supracitada temos os seguintes tópicos a considerar:

    • A função CONT.SE(A2:A13;A2:A13) armazenará em uma matriz todos os valores dos alunos, ou seja, teremos a seguinte configuração matricial {1;2;2;3;3;3;4;4;4;4;2;2}, sendo a sua interpretação a seguinte, na posição 1 (Célula A2), temos somente 1 elemento (João), na posição 2 e 3 (Intervalo A3:A4), temos 2 elementos (Maria), na posição 4, 5, 6 (Intervalo A5:A7), temos 3 elementos (Huguinho), e assim por diante.
    • Quando dividimos 1 por CONT.SE(A2:A13;A2:13a matriz terá os os seus valores divididos, assumindo o seguinte resultado, {1;0,5;0,5;0,333…;0,333…;0,333..;0,25;0,25;0,25;0,25;0,5;0,5}.
    • A função SOMA é aplicada com o intuito de somar as frequências de cada elemento da matriz, sendo esta soma igual a contagem de valores não repetidos. Vamos entender melhor este fato:
1 = 1 (João)
0,5 + 0,5 = 1 (Maria)
0,333… + 0,333… + 0,333… = 1 (Huguinho)
0,25 + 0,25 + 0,25 + 0,25 = 1 (Zezinho)
0,5 + 0,5 = 1 (Luizinho)
    • Após a construção da fórmula, SOMA(1/CONT.SE(A2:A13;A2:A13)), pressionar Crtl+ Shift + Enter , pois trata-se de uma fórmula matricial, com isso, aparecerá o símbolo de chaves “{” envolvendo a formula,{=SOMA(1/CONT.SE(A2:A13;A2:A13))}.

Obs.: Não adianta inserir chaves no início e no final da fórmula manualmente, o procedimento de pressionar Crtl + Shift + Enter é mandatório.

2ºModo


= SOMARPRODUTO(1/CONT.SE(Intervalo;Intervalo))

Perceba que o único elemento que difere o 2º modo do 1º modo é a ausência das chaves, isto ocorre porque a função SOMARPRODUTO possui características matriciais.

Bons estudos e espero que tenham gostado!

3 thoughts on “Contagem com valores repetidos

  1. Rosangela Duarte says:

    Professor, dentro do exemplo que deu, eu gostaria que fossem somados nesta condição, só aquelas pessoas que pertençam a determinada diretoria. Como posso acrescentar uma segunda condição?

    • Carlos Roberto Roa says:

      Boa Noite Rosangela,

      Para adicionar mais uma condição a fórmula, você deverá implementar da seguinte forma:
      =SOMARPRODUTO(1/(CONT.SES(intervalo1;intervalo1;intervalo2;intervalo2)))

      Espero ter ajudado!
      Um grande abraço

  2. GIOVANNI GONCALVES says:

    Olá, Carlos!! Usei a formula e mesmo usando a matriz ela não funcionou. Não consegui encontrar o motivo, pois uso na forma de tabela, e preciso de 4 condições.
    A planilha precisa contar o numero de clientes atendidos, sem repetições, pelo mesmo representante num determinado período com uma marca específica. Fica fácil quando filtro pela tabela dinâmica, mas gostaria disso automático na formula.

    Consegue me ajudar?

Deixe uma resposta

%d blogueiros gostam disto: