Como tratar Erros em Fórmulas

Os erros em fórmulas podem surgir devido a diversos motivos, desde uma inconsistência nos parâmetros de uma fórmula até uma divisão por zero, no entanto, o Excel sinaliza o tipo de erro, permitindo-se assim, entender melhor o porquê de tal resultado.

É interessante ressaltar que em muitos casos a sinalização de um erro, não é algo negativo, e pode até mesmo ser proposital, como por exemplo, a aplicação da função NÃO.DISP(), para retorna um erro do tipo #N/D em células vazias, possibilitando assim, a geração de um gráfico de linha truncado no ponto que não existe informação.

De um modo geral a visualização de um erro é algo incômodo e esteticamente desagradável, e que com técnicas podem ser tratados de forma conveniente, gerando-se um resultado mais limpo, organizado e apresentável.

Tipos de Erros

É importante entender os tipos de erros para direcionar o tratamento a estes, de uma forma assertiva, sendo assim, segue uma tabela orientativa com os tipos de erros que poderemos nos deparar.

Lista_erros2
Figura 1 – Lista com os tipo de erros em fórmulas.

Consulte os pots Elementos básicos de uma planilha e Operadores de Cálculo, para entender melhor certos conceitos, limitações e variáveis que podem contribuir para diferentes tipo de erros.

Funções para tratamento de Erro

Existem variadas formas de se tratar um erro, sendo assim, segue uma lista com as funções que são aplicadas para tratamento de erro.

funcoes_erro
Figura 2 – Lista com as funções para tratamentos de erros.

Tratando um Erro

Após conhecer os tipos de erros e as funções para o tratamento destes, é interessante notar que uma grande parte das funções não possui um efeito tão interessante de forma individual, visto que, somente retorna o resultado VERDADEIRO ou FALSO, sendo assim, veremos alguns exemplos com a função SE combinada.

Exemplo 1: Bhaskara

Imagine uma prova de matemática, em que temos que estudar Bhaskara, sabemos que valores de Delta (Δ) negativos, não possui solução real, sendo assim, neste caso temos que indicar que as soluções x1 e x2, possuem raízes imaginárias.

Resultado de imagem para bhaskara

Delta_erro

Δ: C4^2-4*C4*C5

=SERRO(Δ;“”)

A fórmula acima calcula o valor de Delta (Δ), e possui a seguinte interpretação, SE Δ for calculado (erro FALSO), então apresente o resultado de Δ, senão retorne vazio (“”). Caso inserirmos algum caractere que não seja numérico em a, b ou c, a fórmula não será calculada (erro VERDADEIRO), e exibirá vazio.

valorx_erro

x1: (-$C$4+RAIZ($C$6))/(2*$C$3)

x2: (-$C$4-RAIZ($C$6))/(2*$C$3)

=SE(ÉERROS(x1);raiz imaginária; x1)

=SE(ÉERROS(x2);raiz imaginária; x2)

As fórmulas acima calculam o valor de x1 e x2, e possuem as seguintes interpretações, SE x1 ou x2 retornar um erro (erro VERDADEIRO), então retorne,  “raiz imaginária”, senão calcule o valor de x1 ou x2. No cálculo acima poderemos ter dois tipos de erro, um erro do tipo #VALOR!, caso inserirmos caracteres não numéricos em a, b ou c; ou um erro do tipo #NÚM!, se Δ assumir um valor negativo, já que, não existe raiz quadrada no campo dos reais. 

raizes_erro

Obs.: Perceba, que o tratamento de erro de x1 e x2, poderia ser contornado, com a função SEERRO, tornando-se a fórmula mais enxuta, no entanto, utilizamos a combinação da fórmula SE + ÉERROS, que possui como benefício a compatibilidade em versões anteriores ao Excel 2007.

Exemplo 2: Jogo de Tabuleiro

Imagine que você esteja entretido com um jogo de tabuleiro, quando lançado um dado, e seu valor for um número par, você andará “x” casas, ao contrário, pulará a sua vez.

funcao_par

A fórmula acima tem a seguinte interpretação, SE o valor do número aleatório entre 1 e 6 for par, ou seja, tiver resultado VERDADEIRO, retorne, “Ande (número aleatório entre 1 e 6) casas”, ao contrário, “Pule a sua vez!”.

lanc_dado

Obs.: O exemplo acima não trata um erro propriamente dito, mas a forma que é lidado a informação, é idêntica ao de um erro. Para se entender melhor isto, devemos imaginar que pelo fato de o número ser par,  é um “erro”.

Espero que tenham gostado e bons estudos!

Deixe uma resposta

%d blogueiros gostam disto: